CodeRabbit - Incident: CodeRabbit not able to authenticate to GitHub – Incident details

Incident: CodeRabbit not able to authenticate to GitHub

Resolved
Major outage
Started 7 days agoLasted about 1 hour

Affected

Website

Operational from 10:43 PM to 10:43 PM, Major outage from 10:43 PM to 11:51 PM

Reviews

Operational from 10:43 PM to 10:43 PM, Major outage from 10:43 PM to 11:51 PM

Updates
  • Postmortem
    UTC
    Postmortem

    This is the GitHub incident that comprised the sole cause of this incident - https://www.githubstatus.com/incidents/gxycch3076xk . They do not seem to have counted it as downtime, but because of the nature of our system 35% API downtime for GitHub is 100% downtime for us.

  • Resolved
    UTC
    Resolved

    We have detected GitHub authentications working again. This incident we are considering as resolved.

  • Identified
    UTC
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    UTC
    Investigating

    CodeRabbit is not able to authenticate to GitHub. PRs are not getting reviewed. DownDetector says that there is a GitHub outage currently.

    https://downdetector.com/status/github/